Folgen

php7 Kompabilität mit Ioncube Verschlüsselung

In der Regel sind unsere Plugins mit IONCUBE verschlüsselt.
Dies stellte mit der Veröffentlichung von php7 ein Problem dar.

Zum Ende September'16 wurde nun ein php7 kompatibler IONCUBE Loader vorgestellt:
http://blog.ioncube.com/2016/05/06/beta-php7-ioncube-loaders/

Seit diesem Tag gibt es bei einigen Anwendern ein Verständnisproblem.

IONCUBE selbst, kann in dieser Version immer noch kein php7 Code verschlüsseln.

Encoder: Version 9
Encoding Language: PHP 5.6

Loader decodiert mit Version 6.0.x

Die Verschlüsselung mit IONCUBE besteht aus zwei (Program-)Teilen.

a) der Encoder = Verschlüsselung

b) der Loader = "Lesen"-Decodierung

Wie Sie dem Blogbeitrag von IONCUBE entnehmen können, ist der Loader für php7 veröffentlicht worden. Dies bedeutet im weiteren, dass wir als Plugin Hersteller immer noch kein php7 Code verschlüsseln können.

Sie können jedoch unsere Plugins, die mit diesem Badget  als "kompatibel" markiert sind, mit dem IONCUBE Loader für php7 benutzen. Wenn wir die Freigabe für "ion 9.0" bestätigen, ist der Code unter php7 funktionstüchtig (abwärts auf php 5.6 kompatibel).

Weiterhin deutet dieses Badget an dass auch der Quellcode mit php7 übereinstimmt.

Wir hoffen, Ihnen mit dieser kleinen Erklärung, mehr Verständnis für diese Frage vermittelt zu haben.

War dieser Beitrag hilfreich?
0 von 0 fanden dies hilfreich
Haben Sie Fragen? Anfrage einreichen

Kommentare